Server Requirements for OpenCart Script

System / Server requirements
System Requirements
OpenCart has requirements that must be met for the store to operate properly. 
When selecting a hosting service make sure the following requirements have been met.

These server extensions must be enabled for OpenCart to install properly.

Web Server (Apache suggested)
PHP 5.3+(1.5.x at least 5.2+)
Database (MySQLi suggested)
Required PHP libraries / modules

  • Curl
  • ZIP
  • Zlib
  • GD Library
  • Mcrypt
  • Mbstrings
  • Xml

The above PHP extensions should be available most hosting providers, during the installation process the script will check if they are enabled. Contact your hosting provider if any are missing.